Disturbance at Nordea

Incident Report for Swish

Resolved

The disturbance impacting transactions to and from Nordea has been resolved.
Posted Apr 10, 2025 - 17:17 CEST

Investigating

At the moment, we are experiencing a disturbance impacting transactions to and from Nordea.
Posted Apr 10, 2025 - 17:10 CEST
This incident affected: Ecosystem (Nordea).