Disturbance affecting Svea Bank

Incident Report for Swish

Resolved

The disturbance affecting transactions to and from Svea Bank has been resolved.
Posted Jul 19, 2024 - 09:08 CEST

Investigating

At the moment, we are experiencing a disturbance affecting transactions to and from Svea Bank.
Posted Jul 19, 2024 - 09:05 CEST
This incident affected: Ecosystem (Svea Bank).