Disturbance impacting Länsförsäkringar
Incident Report for Swish
Resolved
The disturbance impacting transactions to and from Länsförsäkringar has been resolved.
Posted Sep 14, 2024 - 02:46 CEST
Investigating
At the moment, we are experiencing a disturbance impacting transactions to and from Länsförsäkringar.
Posted Sep 14, 2024 - 02:30 CEST
This incident affected: Ecosystem (Länsförsäkringar).