Disturbance affecting Marginalen Bank
Incident Report for Swish
Resolved
The disturbance affecting transactions to and from Marginalen Bank has been resolved.
Posted 5 months ago. Sep 08, 2024 - 02:32 CEST
Investigating
At the moment, we are experiencing a disturbance affecting transactions to and from Marginalen Bank.
Posted 5 months ago. Sep 08, 2024 - 01:50 CEST
This incident affected: Ecosystem (Marginalen Bank).