Disturbance impacting Nordea
Incident Report for Swish
Resolved
The disturbance impacting transactions to and from Nordea has been resolved.
Posted Dec 14, 2024 - 12:35 CET
Investigating
At the moment, we are experiencing a disturbance impacting transactions to and from Nordea.
Posted Dec 14, 2024 - 12:31 CET
This incident affected: Ecosystem (Nordea).