Disturbance at Marginalen Bank

Incident Report for Swish

Resolved

The disturbance impacting transactions to and from Marginalen Bank has been resolved.
Posted Mar 25, 2025 - 10:16 CET

Investigating

At the moment, we are experiencing a disturbance impacting transactions to and from Marginalen Bank.
Posted Mar 25, 2025 - 10:06 CET
This incident affected: Ecosystem (Marginalen Bank).