Disturbance at Swish

Incident Report for Swish

Resolved

The disturbance at Swish has been resolved.
Posted May 22, 2025 - 15:42 CEST

Monitoring

We are still experiencing a disturbance at Swish impacting Swish payments.
Posted May 22, 2025 - 15:40 CEST

Identified

The incident has been identified at one of our suppliers. We are working to resolve the issue.
Posted May 22, 2025 - 14:52 CEST

Update

We are still experiencing a disturbance at Swish impacting Swish payments.
Posted May 22, 2025 - 14:02 CEST

Investigating

At the moment, we are experiencing a disturbance at Swish impacting Swish payments.
Posted May 22, 2025 - 13:02 CEST
This incident affected: Private, Business (& Business App), Commerce, Payout, Recurring (Recurring Payments, Recurring Consent creation), and Supporting Services (Payment History, Private Payment Request).