Disturbance at Swish
Incident Report for Swish
Resolved
The disturbance at Swish has been resolved.
Posted Oct 10, 2024 - 03:18 CEST
Investigating
At the moment, we are experiencing a disturbance at Swish impacting Swish payments.
Posted Oct 10, 2024 - 03:07 CEST
This incident affected: Commerce.