Disturbance affecting Nordea
Incident Report for Swish
Resolved
The disturbance affecting transactions to and from Nordea has been resolved.
Posted Jul 07, 2024 - 18:00 CEST
Investigating
At the moment, we are experiencing a disturbance affecting transactions to and from Nordea.
Posted Jul 07, 2024 - 16:53 CEST
This incident affected: Ecosystem (Nordea).