Disturbance at Nordea

Incident Report for Swish

Resolved

The disturbance impacting transactions to and from Nordea has been resolved.
Posted Feb 13, 2025 - 22:11 CET

Investigating

At the moment, we are experiencing a disturbance impacting transactions to and from Nordea.
Posted Feb 13, 2025 - 22:01 CET
This incident affected: Ecosystem (Nordea).