Disturbance affecting Handelsbanken
Incident Report for Swish
Resolved
The disturbance affecting transactions to and from Handelsbanken is now solved and Swish payments work as normal again.
Posted Jun 16, 2024 - 08:35 CEST
Investigating
At the moment we are experiencing disturbances that affects transactions to and from Handelsbanken.
Posted Jun 16, 2024 - 08:00 CEST
This incident affected: Ecosystem (Handelsbanken).