Disturbance impacting Nordea
Incident Report for Swish
Resolved
The disturbance impacting transactions to and from Nordea has been resolved.
Posted Nov 20, 2024 - 20:30 CET
Investigating
At the moment, we are experiencing a disturbance impacting transactions to and from Nordea.
Posted Nov 20, 2024 - 20:24 CET
This incident affected: Ecosystem (Nordea).