Disturbance at Svea Bank

Incident Report for Swish

Resolved

The disturbance impacting transactions to and from Svea Bank has been resolved.
Posted Mar 13, 2025 - 08:26 CET

Investigating

At the moment, we are experiencing a disturbance impacting transactions to and from Svea Bank.
Posted Mar 13, 2025 - 07:00 CET
This incident affected: Ecosystem (Svea Bank).