Disturbance impacting Swedbank
Incident Report for Swish
Resolved
The disturbance impacting transactions to and from Swedbank has been resolved.
Posted Oct 16, 2024 - 02:43 CEST
Investigating
At the moment, we are experiencing a disturbance impacting transactions to and from Swedbank.
Posted Oct 16, 2024 - 02:37 CEST
This incident affected: Ecosystem (Swedbank).