Disturbance at Swish

Incident Report for Swish

Resolved

The disturbance at Swish has been resolved.
Posted May 06, 2025 - 12:55 CEST

Identified

We are still experiencing a disturbance at Swish impacting Swish payments.
Posted May 06, 2025 - 12:50 CEST

Investigating

At the moment, we are experiencing a disturbance at Swish impacting Swish payments.
Posted May 06, 2025 - 11:58 CEST
This incident affected: Private, Business (& Business App), Commerce, Payout and Recurring (Recurring Payments, Recurring Consent creation).