Disturbance at Lunar

Incident Report for Swish

Resolved

The disturbance impacting transactions to and from Lunar has been resolved.
Posted Apr 25, 2025 - 14:51 CEST

Investigating

At the moment, we are experiencing a disturbance impacting transactions to and from Lunar.
Posted Apr 25, 2025 - 14:40 CEST
This incident affected: Ecosystem (Lunar).