Disturbance impacting Skandiabanken
Incident Report for Swish
Resolved
The disturbance impacting transactions to and from Skandiabanken has been resolved.
Posted Oct 08, 2024 - 21:40 CEST
Investigating
At the moment, we are experiencing a disturbance impacting transactions to and from Skandiabanken.
Posted Oct 08, 2024 - 20:46 CEST
This incident affected: Ecosystem (Skandiabanken).