Disturbance impacting Lunar
Incident Report for Swish
Resolved
The disturbance impacting transactions to and from Lunar has been resolved.
Posted Nov 07, 2024 - 12:52 CET
Investigating
At the moment, we are experiencing a disturbance impacting transactions to and from Lunar.
Posted Nov 07, 2024 - 08:54 CET
This incident affected: Ecosystem (Lunar).