Disturbance at Swish
Incident Report for Swish
Resolved
The disturbance at Swish has been resolved.
Posted Nov 17, 2024 - 12:00 CET
Investigating
At the moment, we are experiencing a disturbance at Swish impacting Swish payments.
Posted Nov 17, 2024 - 11:28 CET
This incident affected: Private, Business (& Business App), Commerce and Recurring (Recurring Payments, Recurring Consent creation).