Disturbance at Swedbank
Incident Report for Swish
Resolved
The disturbance impacting transactions to and from Swedbank has been resolved.
Posted Feb 03, 2025 - 06:40 CET
Investigating
At the moment, we are experiencing a disturbance impacting transactions to and from Swedbank.
Posted Feb 03, 2025 - 01:54 CET
This incident affected: Ecosystem (Swedbank).