Disturbance at Marginalen Bank

Incident Report for Swish

Resolved

The disturbance impacting transactions to and from Marginalen Bank has been resolved.
Posted Mar 14, 2025 - 09:04 CET

Investigating

At the moment, we are experiencing a disturbance impacting transactions to and from Marginalen Bank.
Posted Mar 14, 2025 - 05:08 CET
This incident affected: Ecosystem (Marginalen Bank).