Disturbance at Nordea

Incident Report for Swish

Resolved

The disturbance impacting transactions to and from Nordea has been resolved.
Posted Apr 09, 2025 - 20:40 CEST

Update

We are continuing to investigate this issue.
Posted Apr 09, 2025 - 19:05 CEST

Investigating

At the moment, we are experiencing a disturbance impacting transactions to and from Nordea.
Posted Apr 09, 2025 - 18:42 CEST
This incident affected: Ecosystem (Nordea).