Disturbance at Swedbank

Incident Report for Swish

Resolved

The disturbance impacting transactions to and from Swedbank has been resolved.
Posted Apr 30, 2025 - 10:21 CEST

Update

We are continuing to investigate this issue.
Posted Apr 30, 2025 - 10:19 CEST

Investigating

At the moment, we are experiencing a disturbance impacting transactions to and from Swedbank.
Posted Apr 30, 2025 - 09:58 CEST
This incident affected: Ecosystem (Swedbank).