Disturbance at Nordea

Incident Report for Swish

Resolved

The disturbance impacting transactions to and from Nordea has been resolved.
Posted Mar 16, 2025 - 01:17 CET

Investigating

At the moment, we are experiencing a disturbance impacting transactions to and from Nordea.
Posted Mar 16, 2025 - 01:13 CET
This incident affected: Ecosystem (Nordea).