Disturbance at Swedbank
Incident Report for Swish
Resolved
The disturbance impacting transactions to and from Swedbank has been resolved.
Posted Jan 13, 2025 - 07:46 CET
Investigating
At the moment, we are experiencing a disturbance impacting transactions to and from Swedbank.
Posted Jan 13, 2025 - 07:41 CET
This incident affected: Ecosystem (Swedbank).