Disturbance impacting ICA Banken
Incident Report for Swish
Resolved
The disturbance impacting transactions to and from ICA Banken has been resolved.
Posted Dec 01, 2024 - 18:54 CET
Investigating
At the moment, we are experiencing a disturbance impacting transactions to and from ICA Banken.
Posted Dec 01, 2024 - 18:38 CET
This incident affected: Ecosystem (ICA Banken).