Disturbance affecting Swedbank

Incident Report for Swish

Resolved

The disturbance affecting transactions to and from Swedbank is now solved and Swish payments work as normal again.
Posted Jun 04, 2024 - 17:41 CEST

Investigating

At the moment we are experiencing disturbances that affects transactions to and from Swedbank.
Posted Jun 04, 2024 - 17:38 CEST
This incident affected: Ecosystem (Swedbank).