Disturbance impacting Lunar
Incident Report for Swish
Resolved
The disturbance impacting transactions to and from Lunar has been resolved.
Posted Nov 06, 2024 - 15:54 CET
Investigating
At the moment, we are experiencing a disturbance impacting transactions to and from Lunar.
Posted Nov 06, 2024 - 15:47 CET
This incident affected: Ecosystem (Lunar).