Disturbance at Skandiabanken
Incident Report for Swish
Resolved
The disturbance impacting transactions to and from Skandiabanken has been resolved.
Posted Feb 03, 2025 - 08:10 CET
Investigating
At the moment, we are experiencing a disturbance impacting transactions to and from Skandiabanken.
Posted Feb 03, 2025 - 07:48 CET
This incident affected: Ecosystem (Skandiabanken).