Disturbance at Swedbank

Incident Report for Swish

Resolved

The disturbance impacting transactions to and from Swedbank has been resolved.
Posted Feb 08, 2025 - 19:20 CET

Investigating

At the moment, we are experiencing a disturbance impacting transactions to and from Swedbank.
Posted Feb 08, 2025 - 19:12 CET
This incident affected: Ecosystem (Swedbank).