Disturbance impacting Nordea
Incident Report for Swish
Resolved
The disturbance impacting transactions to and from Nordea has been resolved.
Posted Oct 08, 2024 - 13:06 CEST
Update
We are continuing to investigate this issue.
Posted Oct 08, 2024 - 09:21 CEST
Investigating
At the moment, we are experiencing a disturbance impacting transactions to and from Nordea.
Posted Oct 08, 2024 - 09:02 CEST
This incident affected: Ecosystem (Nordea).