Disturbance impacting Marginalen Bank
Incident Report for Swish
Resolved
The disturbance impacting transactions to and from Marginalen Bank has been resolved.
Posted Nov 09, 2024 - 08:36 CET
Investigating
At the moment, we are experiencing a disturbance impacting transactions to and from Marginalen Bank.
Posted Nov 09, 2024 - 07:00 CET
This incident affected: Ecosystem (Marginalen Bank).