Disturbance at Länsförsäkringar

Incident Report for Swish

Resolved

The disturbance impacting transactions to and from Länsförsäkringar has been resolved.
Posted Apr 07, 2025 - 12:17 CEST

Investigating

At the moment, we are experiencing a disturbance impacting transactions to and from Länsförsäkringar.
Posted Apr 07, 2025 - 12:11 CEST
This incident affected: Ecosystem (Länsförsäkringar).