Disturbance impacting SEB
Incident Report for Swish
Resolved
The disturbance impacting transactions to and from SEB has been resolved.
Posted Oct 19, 2024 - 10:52 CEST
Investigating
At the moment, we are experiencing a disturbance impacting transactions to and from SEB.
Posted Oct 19, 2024 - 07:53 CEST
This incident affected: Ecosystem (SEB).