Disturbance impacting Swedbank
Incident Report for Swish
Resolved
The disturbance impacting transactions to and from Swedbank has been resolved.
Posted Nov 17, 2024 - 11:24 CET
Investigating
At the moment, we are experiencing a disturbance impacting transactions to and from Swedbank.
Posted Nov 17, 2024 - 10:36 CET
This incident affected: Ecosystem (Swedbank).