Disturbance at Skandiabanken

Incident Report for Swish

Resolved

The disturbance impacting transactions to and from Skandiabanken has been resolved.
Posted May 07, 2025 - 13:09 CEST

Investigating

At the moment, we are experiencing a disturbance impacting transactions to and from Skandiabanken.
Posted May 07, 2025 - 12:27 CEST
This incident affected: Ecosystem (Skandiabanken).