Disturbance at Länsförsäkringar

Incident Report for Swish

Resolved

The disturbance at Länsförsäkringar impacting Swish transactions to and from Länsförsäkringar has been resolved.
Posted Sep 25, 2025 - 13:29 CEST

Investigating

At the moment, Länsförsäkringar is experiencing a disturbance that may impact Swish transactions to and from Länsförsäkringar. For more information and media inquiries, please contact Länsförsäkringar. For questions regarding transactions, please contact your bank.
Posted Sep 25, 2025 - 13:16 CEST
This incident affected: Ecosystem (Länsförsäkringar).