Disturbance impacting Handelsbanken
Incident Report for Swish
Resolved
The disturbance impacting transactions to and from Handelsbanken has been resolved.
Posted Nov 03, 2024 - 01:25 CET
Investigating
At the moment, we are experiencing a disturbance impacting transactions to and from Handelsbanken.
Posted Nov 03, 2024 - 01:16 CET
This incident affected: Ecosystem (Handelsbanken).