Disturbance at Marginalen Bank

Incident Report for Swish

Resolved

The disturbance impacting transactions to and from Marginalen Bank has been resolved.
Posted Apr 08, 2025 - 01:09 CEST

Investigating

At the moment, we are experiencing a disturbance impacting transactions to and from Marginalen Bank.
Posted Apr 07, 2025 - 21:07 CEST
This incident affected: Ecosystem (Marginalen Bank).