Disturbance at Marginalen Bank

Incident Report for Swish

Resolved

The disturbance impacting transactions to and from Marginalen Bank has been resolved.
Posted Mar 24, 2025 - 10:46 CET

Update

We are continuing to investigate this issue.
Posted Mar 24, 2025 - 10:25 CET

Investigating

At the moment, we are experiencing a disturbance impacting transactions to and from Marginalen Bank.
Posted Mar 24, 2025 - 10:22 CET
This incident affected: Ecosystem (Marginalen Bank).