Disturbance impacting Länsförsäkringar
Incident Report for Swish
Resolved
The disturbance impacting transactions to and from Länsförsäkringar has been resolved.
Posted Oct 01, 2024 - 03:20 CEST
Investigating
At the moment, we are experiencing a disturbance impacting transactions to and from Länsförsäkringar.
Posted Oct 01, 2024 - 00:00 CEST
This incident affected: Ecosystem (Länsförsäkringar).