Disturbance at Swish
Incident Report for Swish
Resolved
The disturbance at Swish has been resolved.
Posted Dec 25, 2024 - 15:34 CET
Investigating
At the moment, we are experiencing a disturbance at Swish impacting the possibility to view your payment history in the Swish app. Please check your bank account to review sent and received payments.
Posted Dec 25, 2024 - 13:57 CET
This incident affected: Private, Business (& Business App), Commerce, Payout and Recurring (Recurring Payments, Recurring Consent creation).