Disturbance affecting Handelsbanken
Incident Report for Swish
Resolved
The disturbance affecting transactions to and from Handelsbanken has been resolved.
Posted Jul 15, 2024 - 00:10 CEST
Investigating
At the moment, we are experiencing a disturbance affecting transactions to and from Handelsbanken.
Posted Jul 14, 2024 - 22:56 CEST
This incident affected: Ecosystem (Handelsbanken).