Disturbance at ICA Banken

Incident Report for Swish

Resolved

The disturbance impacting transactions to and from ICA Banken has been resolved.
Posted Apr 09, 2025 - 00:28 CEST

Investigating

At the moment, we are experiencing a disturbance impacting transactions to and from ICA Banken.
Posted Apr 08, 2025 - 23:26 CEST
This incident affected: Ecosystem (ICA Banken).