Disturbance affecting ICA Banken
Incident Report for Swish
Resolved
The disturbance affecting transactions to and from ICA Banken has been resolved.
Posted May 29, 2024 - 02:08 CEST
Investigating
At the moment, we are experiencing a disturbance affecting transactions to and from ICA Banken.
Posted May 29, 2024 - 00:51 CEST
This incident affected: Ecosystem (ICA Banken).