Disturbance at Swish
Incident Report for Swish
Resolved
The disturbance at Swish has been resolved.
Posted Sep 06, 2024 - 13:18 CEST
Investigating
At the moment, we are experiencing a disturbance at Swish impacting Swish payments.
Posted Sep 06, 2024 - 13:14 CEST
This incident affected: Private, Business (& Business App), Commerce, and Payout.