Disturbance at SEB

Incident Report for Swish

Resolved

The disturbance impacting transactions to and from SEB has been resolved.
Posted Feb 16, 2025 - 03:14 CET

Investigating

At the moment, we are experiencing a disturbance impacting transactions to and from SEB.
Posted Feb 16, 2025 - 02:52 CET
This incident affected: Ecosystem (SEB).