Disturbance at Klarna Bank

Incident Report for Swish

Resolved

The disturbance impacting transactions to and from Klarna Bank has been resolved.
Posted May 16, 2025 - 07:08 CEST

Investigating

At the moment, we are experiencing a disturbance impacting transactions to and from Klarna Bank.
Posted May 16, 2025 - 06:59 CEST
This incident affected: Ecosystem (Klarna Bank).