Disturbance affecting Skandiabanken
Incident Report for Swish
Resolved
The disturbance affecting transactions to and from Skandiabanken has been resolved.
Posted Jul 22, 2024 - 03:38 CEST
Investigating
At the moment, we are experiencing a disturbance affecting transactions to and from Skandiabanken.
Posted Jul 21, 2024 - 16:10 CEST
This incident affected: Ecosystem (Skandiabanken).