Disturbance at Swish

Incident Report for Swish

Resolved

The disturbance at Swish has been resolved.
Posted May 06, 2025 - 21:28 CEST

Identified

We are seeing improvements, and transactions are going through. Getswish is continuing to work to fully resolve the issue.
Posted May 06, 2025 - 20:39 CEST

Investigating

At the moment, we are experiencing a disturbance at Swish impacting Swish payments.
Posted May 06, 2025 - 17:10 CEST
This incident affected: Private, Business (& Business App), Commerce, Payout and Recurring (Recurring Payments, Recurring Consent creation).